Dans Edgy, ce qui est sympa, c'est que tous les softs nécessaires sont maintenant packagés, qu'il s'agisse d'eclipse ou du jdk de sun (sans lequel eclipse a vraiment tendance à se trainer... Respect aux gens de gcj, leur cause est noble, mais pour l'instant je continue d'utiliser le jdk de Sun) Vous pouvez donc installer les packages sun-java5-* et eclipse. Un petit sudo update-alternatives --config java, pour être sûr que l'on utilise la bonne jvm, et aussi vérifier dans /etc/eclipse/java-home.

Ensuite j'installe généralement subclipse, qui permet d'accéder aux repositories subversion directement à partir d'eclipse. Et là c'est le drame! Dès que je lance eclipse avec subclipse installé, la jvm plante...

Un rapide rappel pour l'installation de subclipse, puis j'expliquerai d'où vient le problème et comment le corriger.

Installation de subclipse :

Subclipse nécessite les bindings java svn pour fonctionner. Ces bindings sont présents dans le package libsvn-javahl. Il faut installer ce package et depuis Edgy, il n'y a rien d'autre à configurer (avant il fallait éditer le script de démarrage d'eclipse pour lui faire prendre en compte le path vers cette lib). On peut ensuite installer tranquillement le plugin, de la branche stable, qui commence à se faire vieillote, ou de la branche instable, qui n'est pas si instable que cela :) J'utilise pour l'instant la branche instable et je n'ai pas rencontré de problème, voir ici : http://subclipse.tigris.org/callisto.html

Le problème :

Un bug dans la libapr (apache portable runtime) utilisé par la libsvn et donc par les bindings java, fait planter la jvm. Plus d'infos ici : https://launchpad.net/distros/ubuntu/+source/subversion/+bug/62748/

La soluce :

J'ai bêtement suivi les instructions fournies dans le dernier commentaire sur ce bug En attendant qu'une correction soit intégrée dans le package officiel, j'ai recompilé apache en local, avec le flag de compilation qui va bien. En gros, ça fait :

apt-build source apache2

édition du fichier debian/rules dans /var/cache/apt-build/build/apache2-2.0.55, repérage de la ligne

AP2_CONFLAGS = $(CFLAGS) -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall -g

et ajout du flag -D_XOPEN_SOURCE=500, genre

AP2_CONFLAGS = $(CFLAGS) -D_XOPEN_SOURCE=500 -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall -g

ensuite pour recompiler,

apt-build install apache2

et je ne sais pas trop pourquoi, il a encore été nécessaire d'installer le package avec


apt-get upgrade apache2

Pour plus d'infos sur apt-build, voir ici : http://julien.danjou.info/article-apt-build.html

Après tout ça, j'ai fait un petit ldconfig pour être sûr que la dépendance entre libsvn-javahl et la nouvelle libapr se fait correctement (étape probablement inutile) et chezmoicamarche.org !